Commit f0ff0638 authored by Don Gagne's avatar Don Gagne

Bump Linux Qt requirement to 5.3

parent e7d85710
...@@ -59,8 +59,8 @@ Supported builds are 64 bit, built using the clang compiler. ...@@ -59,8 +59,8 @@ Supported builds are 64 bit, built using the clang compiler.
### Build on Linux ### Build on Linux
Supported builds for Linux are 32 or 64-bit, built using gcc. Supported builds for Linux are 32 or 64-bit, built using gcc.
#### Install Qt5.1+ and SDL1.2 prerequistites #### Install Qt5.3+ and SDL1.2 prerequistites
* For Ubuntu: `sudo apt-get install qtcreator qttools5-dev qtbase5-dev qt5-default qtdeclarative5-dev libqt5serialport5-dev libqt5svg5-dev libqt5webkit5-dev libsdl1.2-dev build-essential libudev-dev` * For Ubuntu (requires 14.10 for Qt5.3): `sudo apt-get install qtcreator qttools5-dev qtbase5-dev qt5-default qtdeclarative5-dev libqt5serialport5-dev libqt5svg5-dev libqt5webkit5-dev libsdl1.2-dev build-essential libudev-dev`
* For Fedora: `sudo yum install qt-creator qt5-qtbase-devel qt5-qtdeclarative-devel qt5-qtserialport-devel qt5-qtsvg-devel qt5-qtwebkit-devel SDL-devel SDL-static systemd-devel` * For Fedora: `sudo yum install qt-creator qt5-qtbase-devel qt5-qtdeclarative-devel qt5-qtserialport-devel qt5-qtsvg-devel qt5-qtwebkit-devel SDL-devel SDL-static systemd-devel`
* For Arch Linux: `pacman -Sy qtcreator qt5-base qt5-declarative qt5-serialport qt5-svg qt5-webkit` * For Arch Linux: `pacman -Sy qtcreator qt5-base qt5-declarative qt5-serialport qt5-svg qt5-webkit`
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment